7 DAEMONS=("bgpd" "isisd" "ospf6d" "ospfd" "pimd" "ripd" "ripngd")
10 for daemon in "${DAEMONS[@]}" zebra
12 cp /usr/share/doc/quagga-core/examples/${daemon}.conf.sample \
13 /etc/quagga/${daemon}.conf
16 # start (no zebra - it's brought up automaticall as a dependency)
17 for daemon in "${DAEMONS[@]}"
19 systemctl start ${daemon}
22 # reload quagga by restarting zebra - dependent daemons will restart.
23 systemctl restart zebra
25 # wait for things to settle
29 for daemon in "${DAEMONS[@]}" zebra
31 echo -n "check ${daemon} - "
32 if systemctl -q is-active ${daemon}; then
35 echo "ERROR: ${daemon} IS NOT RUNNING"