1 From: Scott Leggett <scott@sl.id.au>
2 Date: Sat, 12 Nov 2016 01:58:52 +1100
3 Subject: Fix spelling errors in strings flagged by lintian.
9 bgpd/bgp_packet.c | 2 +-
11 isisd/isis_spf.c | 2 +-
16 lib/sockunion.c | 2 +-
19 ospf6d/ospf6_area.c | 6 +++---
20 ospfd/ospf_te.h | 2 +-
22 tests/aspath_test.c | 2 +-
23 vtysh/vtysh_config.c | 2 +-
24 zebra/interface.c | 22 +++++++++++-----------
25 zebra/irdp_packet.c | 4 ++--
26 zebra/kernel_socket.c | 2 +-
27 21 files changed, 35 insertions(+), 35 deletions(-)
29 diff --git a/bgpd/bgp_attr.c b/bgpd/bgp_attr.c
30 index a79a03c..7ba8148 100644
33 @@ -2320,7 +2320,7 @@ bgp_attr_parse (struct peer *peer, struct attr *attr, bgp_size_t size,
34 ret = BGP_ATTR_PARSE_ERROR;
37 - /* If hard error occured immediately return to the caller. */
38 + /* If hard error occurred immediately return to the caller. */
39 if (ret == BGP_ATTR_PARSE_ERROR)
41 zlog (peer->log, LOG_WARNING,
42 diff --git a/bgpd/bgp_damp.c b/bgpd/bgp_damp.c
43 index ac64723..aa514ce 100644
46 @@ -663,7 +663,7 @@ bgp_show_dampening_parameters (struct vty *vty, afi_t afi, safi_t safi)
47 damp->suppress_value, VTY_NEWLINE);
48 vty_out (vty, "Max suppress time: %ld min%s",
49 damp->max_suppress_time / 60, VTY_NEWLINE);
50 - vty_out (vty, "Max supress penalty: %u%s",
51 + vty_out (vty, "Max suppress penalty: %u%s",
52 damp->ceiling, VTY_NEWLINE);
53 vty_out (vty, "%s", VTY_NEWLINE);
55 diff --git a/bgpd/bgp_fsm.c b/bgpd/bgp_fsm.c
56 index 4198a8e..1ddd4ce 100644
59 @@ -391,7 +391,7 @@ bgp_graceful_stale_timer_expire (struct thread *thread)
63 -/* Called after event occured, this function change status and reset
64 +/* Called after event occurred, this function change status and reset
65 read/write and timer thread. */
67 bgp_fsm_change_status (struct peer *peer, int status)
68 diff --git a/bgpd/bgp_packet.c b/bgpd/bgp_packet.c
69 index b497e45..b3d601f 100644
70 --- a/bgpd/bgp_packet.c
71 +++ b/bgpd/bgp_packet.c
72 @@ -2476,7 +2476,7 @@ bgp_read_packet (struct peer *peer)
73 /* Read packet from fd. */
74 nbytes = stream_read_try (peer->ibuf, peer->fd, readsize);
76 - /* If read byte is smaller than zero then error occured. */
77 + /* If read byte is smaller than zero then error occurred. */
80 /* Transient error should retry */
81 diff --git a/bgpd/bgp_vty.c b/bgpd/bgp_vty.c
82 index 0040d62..abd01ce 100644
85 @@ -4340,7 +4340,7 @@ ALIAS (neighbor_allowas_in,
88 "Accept as-path with my AS present in it\n"
89 - "Number of occurances of AS number\n")
90 + "Number of occurrences of AS number\n")
92 DEFUN (no_neighbor_allowas_in,
93 no_neighbor_allowas_in_cmd,
94 diff --git a/isisd/isis_spf.c b/isisd/isis_spf.c
95 index 6b2456f..82d743b 100644
96 --- a/isisd/isis_spf.c
97 +++ b/isisd/isis_spf.c
98 @@ -1033,7 +1033,7 @@ isis_spf_preload_tent (struct isis_spftree *spftree, int level,
100 case ISIS_SYSTYPE_UNKNOWN:
102 - zlog_warn ("isis_spf_preload_tent unknow adj type");
103 + zlog_warn ("isis_spf_preload_tent unknown adj type");
106 list_delete (adj_list);
107 diff --git a/lib/command.c b/lib/command.c
108 index 662f8a3..bcd507b 100644
111 @@ -1700,7 +1700,7 @@ cmd_element_match(struct cmd_element *cmd_element,
112 * That vector will contain all struct command_token* of the
113 * cmd_element which matched against the given vline at the given
115 - * @return A code specifying if an error occured. If all went right, it's
116 + * @return A code specifying if an error occurred. If all went right, it's
120 diff --git a/lib/command.h b/lib/command.h
121 index cc5dd08..60079b3 100644
124 @@ -502,7 +502,7 @@ struct cmd_token
125 #define IN_STR "Filter incoming routing updates\n"
126 #define V4NOTATION_STR "specify by IPv4 address notation(e.g. 0.0.0.0)\n"
127 #define OSPF6_NUMBER_STR "Specify by number\n"
128 -#define INTERFACE_STR "Interface infomation\n"
129 +#define INTERFACE_STR "Interface information\n"
130 #define IFNAME_STR "Interface name(e.g. ep0)\n"
131 #define IP6_STR "IPv6 Information\n"
132 #define OSPF6_STR "Open Shortest Path First (OSPF) for IPv6\n"
133 diff --git a/lib/memory.c b/lib/memory.c
134 index b8305dd..54a8ce4 100644
137 @@ -43,7 +43,7 @@ static const struct message mstr [] =
141 -/* Fatal memory allocation error occured. */
142 +/* Fatal memory allocation error occurred. */
143 static void __attribute__ ((noreturn))
144 zerror (const char *fname, int type, size_t size)
146 diff --git a/lib/regex.c b/lib/regex.c
147 index 122f447..cedf499 100644
150 @@ -5726,7 +5726,7 @@ regcomp (preg, pattern, cflags)
152 if (re_compile_fastmap (preg) == -2)
154 - /* Some error occured while computing the fastmap, just forget
155 + /* Some error occurred while computing the fastmap, just forget
157 free (preg->fastmap);
158 preg->fastmap = NULL;
159 diff --git a/lib/sockunion.c b/lib/sockunion.c
160 index 8e0ec24..9642c1c 100644
161 --- a/lib/sockunion.c
162 +++ b/lib/sockunion.c
163 @@ -286,7 +286,7 @@ sockunion_log (const union sockunion *su, char *buf, size_t len)
166 /* sockunion_connect returns
168 + -1 : error occurred
170 1 : connect is in progress */
172 diff --git a/lib/vty.c b/lib/vty.c
173 index 7ca8354..d28fd27 100644
176 @@ -2432,7 +2432,7 @@ vty_read_file (FILE *confp)
177 fprintf (stderr, "*** Error reading config: There is no such command.\n");
180 - fprintf (stderr, "*** Error occured processing line %u, below:\n%s\n",
181 + fprintf (stderr, "*** Error occurred processing line %u, below:\n%s\n",
185 diff --git a/lib/vty.h b/lib/vty.h
186 index 1e3b124..b292db1 100644
189 @@ -168,7 +168,7 @@ do { \
190 * The logic below ((TMPL) <= ((MIN) && (TMPL) != (MIN)) is
191 * done to circumvent the compiler complaining about
192 * comparing unsigned numbers against zero, if MIN is zero.
193 - * NB: The compiler isn't smart enough to supress the warning
194 + * NB: The compiler isn't smart enough to suprress the warning
195 * if you write (MIN) != 0 && tmpl < (MIN).
197 #define VTY_GET_INTEGER_RANGE_HEART(NAME,TMPL,STR,MIN,MAX) \
198 diff --git a/ospf6d/ospf6_area.c b/ospf6d/ospf6_area.c
199 index 1861fe7..6d82e72 100644
200 --- a/ospf6d/ospf6_area.c
201 +++ b/ospf6d/ospf6_area.c
202 @@ -657,7 +657,7 @@ DEFUN (show_ipv6_ospf6_spf_tree,
206 - "Shortest Path First caculation\n"
207 + "Shortest Path First calculation\n"
210 struct listnode *node;
211 @@ -694,7 +694,7 @@ DEFUN (show_ipv6_ospf6_area_spf_tree,
215 - "Shortest Path First caculation\n"
216 + "Shortest Path First calculation\n"
220 @@ -738,7 +738,7 @@ DEFUN (show_ipv6_ospf6_simulate_spf_tree_root,
224 - "Shortest Path First caculation\n"
225 + "Shortest Path First calculation\n"
227 "Specify root's router-id to calculate another router's SPF tree\n")
229 diff --git a/ospfd/ospf_te.h b/ospfd/ospf_te.h
230 index 8bb77c4..d80629c 100644
231 --- a/ospfd/ospf_te.h
232 +++ b/ospfd/ospf_te.h
233 @@ -386,7 +386,7 @@ struct te_link_subtlv
234 /* Following structure are internal use only. */
237 - /* Status of MPLS-TE: enable or disbale */
238 + /* Status of MPLS-TE: enable or disable */
242 diff --git a/ripd/ripd.c b/ripd/ripd.c
243 index c073eca..3866624 100644
246 @@ -2538,14 +2538,14 @@ rip_update_process (int route_type)
247 ifp = if_lookup_address (p->prefix);
250 - zlog_warn ("Neighbor %s doesnt have connected interface!",
251 + zlog_warn ("Neighbor %s doesn't have connected interface!",
252 inet_ntoa (p->prefix));
256 if ( (connected = connected_lookup_address (ifp, p->prefix)) == NULL)
258 - zlog_warn ("Neighbor %s doesnt have connected network",
259 + zlog_warn ("Neighbor %s doesn't have connected network",
260 inet_ntoa (p->prefix));
263 diff --git a/tests/aspath_test.c b/tests/aspath_test.c
264 index 5a0899e..d970211 100644
265 --- a/tests/aspath_test.c
266 +++ b/tests/aspath_test.c
267 @@ -1037,7 +1037,7 @@ validate (struct aspath *as, const struct test_spec *sp)
269 printf ("firstas: %d, got %d\n", sp->first,
270 aspath_firstas_check (as,sp->first));
271 - printf ("loop does: %d %d, doesnt: %d %d\n",
272 + printf ("loop does: %d %d, doesn't: %d %d\n",
273 sp->does_loop, aspath_loop_check (as, sp->does_loop),
274 sp->doesnt_loop, aspath_loop_check (as, sp->doesnt_loop));
275 printf ("private check: %d %d\n", sp->private_as,
276 diff --git a/vtysh/vtysh_config.c b/vtysh/vtysh_config.c
277 index 2834ef4..143aa77 100644
278 --- a/vtysh/vtysh_config.c
279 +++ b/vtysh/vtysh_config.c
280 @@ -400,7 +400,7 @@ vtysh_read_file (FILE *confp)
281 fprintf (stderr, "There is no such command.\n");
284 - fprintf (stderr, "Error occured during reading below line.\n%s\n",
285 + fprintf (stderr, "Error occurred during reading below line.\n%s\n",
289 diff --git a/zebra/interface.c b/zebra/interface.c
290 index f8b946f..ebb03ae 100644
291 --- a/zebra/interface.c
292 +++ b/zebra/interface.c
293 @@ -1143,7 +1143,7 @@ DEFUN (show_interface_name, show_interface_name_cmd,
294 "show interface IFNAME",
296 "Interface status and configuration\n"
298 + "Interface name\n")
300 struct interface *ifp;
301 vrf_id_t vrf_id = VRF_DEFAULT;
302 @@ -1178,7 +1178,7 @@ ALIAS (show_interface_name,
303 "show interface IFNAME " VRF_CMD_STR,
305 "Interface status and configuration\n"
310 /* Show specified interface to vty. */
311 @@ -1186,7 +1186,7 @@ DEFUN (show_interface_name_vrf_all, show_interface_name_vrf_all_cmd,
312 "show interface IFNAME " VRF_ALL_CMD_STR,
314 "Interface status and configuration\n"
317 VRF_ALL_CMD_HELP_STR)
319 struct interface *ifp;
320 @@ -1706,7 +1706,7 @@ DEFUN (no_link_params_metric,
321 no_link_params_metric_cmd,
324 - "Disbale Link Metric on this interface\n")
325 + "Disable Link Metric on this interface\n")
327 struct interface *ifp = (struct interface *) vty->index;
329 @@ -1861,7 +1861,7 @@ DEFUN (no_link_params_admin_grp,
330 no_link_params_admin_grp_cmd,
333 - "Disbale Administrative group membership on this interface\n")
334 + "Disable Administrative group membership on this interface\n")
336 struct interface *ifp = (struct interface *) vty->index;
338 @@ -2031,7 +2031,7 @@ DEFUN (no_link_params_delay,
339 no_link_params_delay_cmd,
342 - "Disbale Unidirectional Average, Min & Max Link Delay on this interface\n")
343 + "Disable Unidirectional Average, Min & Max Link Delay on this interface\n")
345 struct interface *ifp = (struct interface *) vty->index;
346 struct if_link_params *iflp = if_link_params_get (ifp);
347 @@ -2072,7 +2072,7 @@ DEFUN (no_link_params_delay_var,
348 no_link_params_delay_var_cmd,
349 "no delay-variation",
351 - "Disbale Unidirectional Delay Variation on this interface\n")
352 + "Disable Unidirectional Delay Variation on this interface\n")
354 struct interface *ifp = (struct interface *) vty->index;
356 @@ -2112,7 +2112,7 @@ DEFUN (no_link_params_pkt_loss,
357 no_link_params_pkt_loss_cmd,
360 - "Disbale Unidirectional Link Packet Loss on this interface\n")
361 + "Disable Unidirectional Link Packet Loss on this interface\n")
363 struct interface *ifp = (struct interface *) vty->index;
365 @@ -2158,7 +2158,7 @@ DEFUN (no_link_params_res_bw,
366 no_link_params_res_bw_cmd,
369 - "Disbale Unidirectional Residual Bandwidth on this interface\n")
370 + "Disable Unidirectional Residual Bandwidth on this interface\n")
372 struct interface *ifp = (struct interface *) vty->index;
374 @@ -2204,7 +2204,7 @@ DEFUN (no_link_params_ava_bw,
375 no_link_params_ava_bw_cmd,
378 - "Disbale Unidirectional Available Bandwidth on this interface\n")
379 + "Disable Unidirectional Available Bandwidth on this interface\n")
381 struct interface *ifp = (struct interface *) vty->index;
383 @@ -2250,7 +2250,7 @@ DEFUN (no_link_params_use_bw,
384 no_link_params_use_bw_cmd,
387 - "Disbale Unidirectional Utilised Bandwidth on this interface\n")
388 + "Disable Unidirectional Utilised Bandwidth on this interface\n")
390 struct interface *ifp = (struct interface *) vty->index;
392 diff --git a/zebra/irdp_packet.c b/zebra/irdp_packet.c
393 index 0d31050..afe035b 100644
394 --- a/zebra/irdp_packet.c
395 +++ b/zebra/irdp_packet.c
396 @@ -102,7 +102,7 @@ parse_irdp_packet(char *p,
400 - zlog_err ("IRDP: RX length doesnt match IP length");
401 + zlog_err ("IRDP: RX length doesn't match IP length");
405 @@ -113,7 +113,7 @@ parse_irdp_packet(char *p,
409 - /* XXX: RAW doesnt receive link-layer, surely? ??? */
410 + /* XXX: RAW doesn't receive link-layer, surely? ??? */
411 /* Check so we don't checksum packets longer than oure RX_BUF - (ethlen +
412 len of IP-header) 14+20 */
413 if (iplen > IRDP_RX_BUF-34)
414 diff --git a/zebra/kernel_socket.c b/zebra/kernel_socket.c
415 index 64c6cbb..9cd6332 100644
416 --- a/zebra/kernel_socket.c
417 +++ b/zebra/kernel_socket.c
418 @@ -476,7 +476,7 @@ ifm_read (struct if_msghdr *ifm)
419 if (ifnlen && (strncmp (ifp->name, ifname, IFNAMSIZ) != 0) )
421 if (IS_ZEBRA_DEBUG_KERNEL)
422 - zlog_debug ("%s: ifp name %s doesnt match sdl name %s",
423 + zlog_debug ("%s: ifp name %s doesn't match sdl name %s",
424 __func__, ifp->name, ifname);