Add a requirement for Net::* 3.0+
authorDan Boger <zigdon@irc.peeron.com>
Thu, 22 Oct 2009 19:35:45 +0000 (12:35 -0700)
committerDan Boger <zigdon@irc.peeron.com>
Thu, 22 Oct 2009 19:35:45 +0000 (12:35 -0700)
twirssi.pl

index 80ee243..5ab53c1 100644 (file)
@@ -11,7 +11,7 @@ $Data::Dumper::Indent = 1;
 
 use vars qw($VERSION %IRSSI);
 
-$VERSION = "2.3.0";
+$VERSION = "2.3.1beta";
 %IRSSI   = (
     authors     => 'Dan Boger',
     contact     => 'zigdon@gmail.com',
@@ -490,7 +490,7 @@ sub cmd_login {
     }
     $defservice = $service = ucfirst lc $service;
 
-    eval "use Net::$service";
+    eval "use Net::$service 3.0";
     if ($@) {
         &notice(
             "Failed to load Net::$service when trying to log in as $user: $@");